Monday 4 May 2009

POJ 1318



题:(http://acm.pku.edu.cn/JudgeOnline/problem?id=1318)
Word Amalgamation

Description



In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.

Input



The input contains four parts: 1) a dictionary, which consists of at least one and at most 100 words, one per line; 2) a line containing XXXXXX, which signals the end of the dictionary; 3) one or more scrambled 'words' that you must unscramble, each on a line by itself; and 4) another line containing XXXXXX, which signals the end of the file. All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.

Output



For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line "NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

Sample Input



tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX

Sample Output



score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******

Source





解:
自己瞎掰的hash,以前做浙大的某个比赛时也这么折腾的来着,感觉还挺好用。
#include <iostream>
#include <map>
#include <set>
#include <string>
using namespace std;
typedef char wordtype[16];
typedef unsigned int uint;

class dic {
map<uint,set<string> > mp[6];
public:
dic(){}
~dic(){}
uint hash(wordtype const& word,int len) const {
uint mask=0;
char ch=1;
for(int i=0;i<len;++i) {
mask|=1<<(word[i]-'a');
ch*=(word[i]-'a'+7);
}
mask|=ch<<26;
return mask;
}
void add_word(wordtype const& word, int len) {
uint h=hash(word,len);
mp[len-1][h].insert(string(word));
}
set<string> & get_words(wordtype const& word, int len) {
uint h=hash(word,len);
return mp[len-1][h];
}
};

int main()
{
dic d;
wordtype word;
for(;cin>>word&&*word!='X';)
d.add_word(word,strlen(word));
for(;cin>>word&&*word!='X';cout<<"******\n") {
set<string> const& p=d.get_words(word, strlen(word));
if(p.empty()){
cout<<"NOT A VALID WORD\n";
} else {
for(set<string>::const_iterator ctr=p.begin();ctr!=p.end();++ctr)
cout<<*ctr<<endl;
}
}
return 0;
}

No comments:

Post a Comment